UK APP - Major Outage

Incident Report for Referoo

Resolved

✅ Resolved automatically for UK APP.
Posted Apr 17, 2025 - 08:55 AEST

Investigating

UK APP is currently experiencing major outage.
Posted Apr 17, 2025 - 08:50 AEST