UK APP - Major Outage

Incident Report for Referoo

Resolved

✅ Resolved automatically for UK APP.
Posted Oct 22, 2025 - 09:25 AEDT

Investigating

UK APP is currently experiencing major outage.
Posted Oct 22, 2025 - 09:20 AEDT