UK APP - Major Outage

Incident Report for Referoo

Resolved

✅ Resolved automatically for UK APP.
Posted Jun 05, 2025 - 23:30 AEST

Investigating

UK APP is currently experiencing major outage.
Posted Jun 05, 2025 - 23:25 AEST